Installation

Optuna supports Python 2.7 and Python 3.4 or newer.

We recommend to install Optuna via pip:

$ pip install optuna

You can also install the development version of Optuna from master branch of Git repository:

$ pip install git+https://github.com/pfnet/optuna.git